Я пытаюсь заставить excel выбрать мой образец аудита, какую формулу я бы использовал для этого?
8/20/2018

У меня есть список из примерно 200 предметов, из которых мне нужно выбрать 10%-ную выборку для проверки информации. Я знаю, что мне нужно выбрать 20 предметов, но я хочу, чтобы excel выбрал мои 20 для меня, а не пытался сделать случайный выбор.

Будем признательны за любую помощь.

Kristin

Ответы (5)

Marguerite Zieme
8/20/2018

Привет, Кристин, Пожалуйста, посмотрите эту ссылку для получения более подробной информации о том, как выбрать образец без дубликатов из данных Excel. https://www.ablebits.com/office-addins-blog/201 ... [https://www.ablebits.com/office-addins-blog/2018/01/31/excel-random-selection-random-sample/#random-selection-without-duplicates] Я надеюсь, что это поможет! С наилучшими пожеланиями, Райан

Помогло 0 людям
Mrs. Jeremy O'Kon
8/20/2018

Давайте предположим, что ваши данные находятся в A2:A201, введите следующую формулу и перетащите вниз на 20 ячеек (это даст неповторяющиеся значения) =ИНДЕКС ($A$2:$A$201, БОЛЬШОЙ(ИНДЕКС(СТРОКА ($1:$200)*НЕ(COUNTIF($A$1:A1, СТРОКА($1:$200))),,), СЛУЧАЙНЫЙ ПРОМЕЖУТОК(1200 СТРОК(A1)+1))) Образец файла загружается в https://1drv.ms/x/s !Akd5y6ruJhvhj1сТоУсЛзА95н6дК [https://1drv.ms/x/s !Akd5y6ruJhvhj1сТоУсЛзА95н6дК]

Помогло 0 людям
Julius Senger
8/20/2018

Спасибо за вашу помощь, но это сложнее, чем случайная сортировка моей выборки и обратный отсчет каждые 12 строк. Поэтому я собираюсь продолжить свой нынешний путь. Но я буду иметь это в виду, когда у меня будет большая группа для выбора. :)

Помогло 0 людям
Julius Senger
8/20/2018

У меня есть 158 строк, из которых нужно выбрать 16 образцов, как бы я использовал это для этого? Перетаскивание вниз 20 строк - это слишком много строк для аудита. Кристин

Помогло 0 людям
Mrs. Jeremy O'Kon
8/20/2018

Используйте приведенную ниже формулу и перетащите ее вниз...После 16 он выдаст пустые результаты = ЕСЛИ(СТРОКА(A1)>16,"", ИНДЕКС($A$2:$A$159, БОЛЬШОЙ(ИНДЕКС(СТРОКА($1:$158)*НЕ(СЧЕТ($A$1:A1, СТРОКА($1:$158))),,), СЛУЧАЙНЫЙ ПРОМЕЖУТОК(1,158-СТРОКА(A1)+1))))

Помогло 0 людям

Похожие вопросы

649

Просмотров

10

Ответов

648

Просмотров

4

Ответов

647

Просмотров

2

Ответов